Enjoy Sharing

Failed to install a new Distribution Point (error 0x800706BA)

When I was trying to install an additional distribution point for a ConfigMgr 2012 R2 environment my installation failed with the following entries in the distmgr.log file.

CWmi::Connect() failed to connect to \root\SCCMDP">\\<servername>\root\SCCMDP. Error = 0x800706BA    SMS_DISTRIBUTION_MANAGER    12/3/2013 11:35:57 AM    2660 (0x0A64)
STATMSG: ID=2391 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_DISTRIBUTION_MANAGER" SYS=<servername>SITE=PS1 PID=3688 TID=2660 GMTDATE=Tue Dec 03 03:35:57.350 2013 ISTR0="["Display=\\<servername>\"]MSWNET:["SMS_SITE=PS1"]\\<servername>\" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=1 AID0=404 AVAL0="["Display=\\<servername>\"]MSWNET:["SMS_SITE=PS1"]\\<servername>\"    SMS_DISTRIBUTION_MANAGER    12/3/2013 11:35:57 AM    2660 (0x0A64)
GetWMIObject – Failed to connect to root\SCCMDP on ["Display=\\<servername>\"]MSWNET:["SMS_SITE=PS1"]\\<servername>\. Error code: 0x800706BA    SMS_DISTRIBUTION_MANAGER    12/3/2013 11:35:57 AM    2660 (0x0A64)
Translated server name <servername> to <domain name>\<servername>.    SMS_DISTRIBUTION_MANAGER    12/3/2013 11:35:57 AM    2660 (0x0A64)
CWmi::Connect() failed to connect to \\<servername>\root\SCCMDP. Error = 0x800706BA    SMS_DISTRIBUTION_MANAGER    12/3/2013 11:35:57 AM    2660 (0x0A64)
STATMSG: ID=2391 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_DISTRIBUTION_MANAGER" SYS=<servername> SITE=PS1 PID=3688 TID=2660 GMTDATE=Tue Dec 03 03:35:57.391 2013 ISTR0="["Display=\\<servername>\"]MSWNET:["SMS_SITE=PS1"]\\<servername>\" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=1 AID0=404 AVAL0="["Display=\\<servername>\"]MSWNET:["SMS_SITE=PS1"]\\<servername>\"    SMS_DISTRIBUTION_MANAGER    12/3/2013 11:35:57 AM    2660 (0x0A64)
CWmiDpRegistry::WmiOpenEx: Failed to connect to WMI namespace root\SCCMDP on machine <servername>SMS_DISTRIBUTION_MANAGER    12/3/2013 11:35:57 AM    2660 (0x0A64)

It looks like it is having difficulty to connect to a certain WMI namespace even though generally it could connect to the server and there’s nothing wrong with connectivity. Checking further on the console when you’re trying to install a package to that DP will give you the following error “failed to distribute content” and a description that says that details will be available after the server finishes processing the messages.

image

 

So the way to solve this is to fix the WMI namespace by parsing a MOF file into the target server that you’re trying to install DP on. Do this by first getting the smsdpprov.mof file from your installation of ConfigMgr and copying it into your target DP server. Typically this is located at <drive:>\Program Files\Microsoft Configuration Manager\bin\X64 in your primary site server. Then all you need to do is to run the below command using the command prompt. Remember to ‘run as administrator’ and change directory to the location where you copied the smsdpprov.mof to but I don’t really need to tell you that 🙂

mofcomp.exe smsdpprov.mof

clip_image002

 

 

 

Enjoy!!!

Advertisements

2 responses

  1. SuperbGrooveMechanics

    good stuff

    February 20, 2014 at 4:52 pm

  2. Cara

    You saved the day for me!

    April 16, 2015 at 8:32 am

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s