Just another WordPress.com site

The software change returned error code 0x87D01281 (-2016406911)

This happened to me while I was working on ConfigMgr 2012 RC2 deploying an App-V package. When trying to deploy an App-V package to a client, it fails with the following error.

SC

Also, you can find this line in the AppEnforce.log on the computer where you’re installing the App-V package.

<![LOG[+++ Starting Install enforcement for App DT "Adb_94 - Microsoft Application Virtualization" ApplicationDeliveryType - ScopeId_F6348A58-DF92-409D-AD18-0CC8727EC74D/DeploymentType_e82cf9a8-02af-459a-963a-40ff62faa6c4, Revision - 3, ContentPath - C:\Windows\ccmcache\2, Execution Context - Any]LOG]!><time="18:15:36.516-480" date="03-06-2012" component="AppEnforce" context="" type="1" thread="1824" file="appprovider.cpp:1624">
<![LOG[    A user is logged on to the system.]LOG]!><time="18:15:36.519-480" date="03-06-2012" component="AppEnforce" context="" type="1" thread="1824" file="appprovider.cpp:1999">
<![LOG[    Performing detection of app deployment type Adb_94 - Microsoft Application Virtualization(ScopeId_F6348A58-DF92-409D-AD18-0CC8727EC74D/DeploymentType_e82cf9a8-02af-459a-963a-40ff62faa6c4, revision 3) for user.]LOG]!><time="18:15:36.520-480" date="03-06-2012" component="AppEnforce" context="" type="1" thread="1824" file="appprovider.cpp:2064">
<![LOG[Installing AppV app (DTId = ScopeId_F6348A58-DF92-409D-AD18-0CC8727EC74D/DeploymentType_e82cf9a8-02af-459a-963a-40ff62faa6c4, Revision = 3)]LOG]!><time="18:15:36.540-480" date="03-06-2012" component="AppEnforce" context="" type="1" thread="1824" file="appvhandler.cpp:778">
<![LOG[The installed AppV version [4.6.0.20200] cannot be used with this version of ConfigMgr.]LOG]!><time="18:15:36.542-480" date="03-06-2012" component="AppEnforce" context="" type="2" thread="1824" file="appvhelperutils.cpp:382">
<![LOG[A supported AppV client is not installed]LOG]!><time="18:15:36.542-480" date="03-06-2012" component="AppEnforce" context="" type="3" thread="1824" file="appvhelperutils.cpp:411">
<![LOG[A supported AppV client is not installed. The AppV package cannot be installed. ]LOG]!><time="18:15:36.542-480" date="03-06-2012" component="AppEnforce" context="" type="3" thread="1824" file="appvhandler.cpp:1127">
<![LOG[++++++ App enforcement completed (0 seconds) for App DT "Adb_94 - Microsoft Application Virtualization" [ScopeId_F6348A58-DF92-409D-AD18-0CC8727EC74D/DeploymentType_e82cf9a8-02af-459a-963a-40ff62faa6c4], Revision: 3, User SID: S-1-5-21-3337967070-97486510-683070264-1117] ++++++]LOG]!><time="18:15:36.543-480" date="03-06-2012" component="AppEnforce" context="" type="1" thread="1824" file="appprovider.cpp:2345">

The cause of this problem is that you may be using an incorrect version of App-V client. The version that is supported is App-V 4.6 with Service Pack 1. Try re-installing with the correct version then try again.

 

 

 

Enjoy!!!

About these ads

3 responses

  1. AzlyAhmad

    I am also facing with this error. Is there any workaround for those who don’t have appV server/client in place…?

    July 31, 2013 at 2:19 pm

    • This should be from those with an App-V package.

      August 12, 2013 at 11:52 am

  2. Could be another cause, tried to search that file but no as such file.

    August 10, 2013 at 3:57 pm

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 51 other followers