Enjoy Sharing

Pre-requisite checker ASP .NET 2.0 error for SCOM

Ever got an error when running the OpsMgr pre-requisite checker that indicates that you do not have the ASP .NET 2.0 component? Hold on a minute! Doesn’t this come together when I applied my .NET Framework 2.0 just a minute ago? Going to the IIS console under Web Extension shows me that I have ASP .NET 1.1 allowed but ASP .NET 2.0 is not there. Installing the IIS component after applying the .NET Framework will not enable the ASP .NET 2.0 component and will give you an error on the OpsMgr pre-requisite checker.

Well, if you ever got this, re-apply .NET Framework 2.0 and select the Repair option. This is simply caused by the sequence you’ve installed IIS component and the .NET Framework. Next time install IIS with the ASP .NET option turned on before you apply .NET Framework 2.0.

 

Enjoy!!!

Advertisements

3 responses

  1. Ray

    the repair can be done via Add/Remove Programs as well. Windows keeps a cached copy of the installation files i guess.. 🙂

    May 31, 2008 at 6:08 pm

  2. Stu

    Try doing it this way, and you should be able to avoid a reinstall
     
    cd %windir%\Microsoft.Net\Framework\v2.0.50727
     
    aspnet_regiis.exe -i
     
    This will reregister ASP.NET with IIS.  This is also useful if you installed .NET 2.0 before you installed IIS as well.

    June 3, 2008 at 1:58 am

  3. Wei King

    Thanks Ray & Stu. If you do not know Ray is also a OpsMgr expert. 🙂

    June 3, 2008 at 7:38 am

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s